當前位置:首頁 » 文件傳輸 » 思科ftp連通性測試
擴展閱讀
webinf下怎麼引入js 2023-08-31 21:54:13
堡壘機怎麼打開web 2023-08-31 21:54:11

思科ftp連通性測試

發布時間: 2022-04-28 13:04:09

① 如何讓路由器和FTP伺服器之間連通,讓PC訪問FTP伺服器

外網訪問內網首先伺服器必須影射到外網地址才可以訪問,如果你的地址是內網的,外網無法訪問,必須登錄路由器映射IP和埠。FTP的埠和外網埠設置也必須一樣,FTP默認21埠,在路由的埠映射里,添加你的IP,也就是192.168.1.100,而埠填21。

方法二

1.在內網安裝nat123軟體。
2.啟用nat123。添加埠映射。選擇自己需要內網發布到外網的應用。如網站應用80埠映射,或其他,或全埠映射所有應用。可以使用自己的頂級域名,或直接使用默認提示的二級域名。
3.域名映射後,用域名訪問即可以了哦。就是這么簡單實現外網訪問內網。
我的伺服器用的是小鳥雲的,訪問很流暢。

② 搭建完FTP以後怎麼測試

具體根據要求測試啊!
一般

1.用不同系統,內外網段的主機連接測試,看看是否正常。

2.用不同的用戶登陸,看看是否可以正常上傳,下載文件。

3.看看不同用戶的的許可權是否合適。
不該看到的目錄或文件是否被屏蔽,
上傳目錄是否屏蔽下載等。

另外網上找下該FTP服務相關的漏洞補丁。

③ java如何測試連接ftp是否通

java測試連接ftp是否連通可以使用判斷是否有異常來決定,實例如下:

/**
*connectServer
*連接ftp伺服器
*@throwsjava.io.IOException
*@parampath文件夾,空代表根目錄
*@parampassword密碼
*@paramuser登陸用戶
*@paramserver伺服器地址
*/
publicvoidconnectServer(Stringserver,Stringuser,Stringpassword,Stringpath)
throwsIOException
{
//server:FTP伺服器的IP地址;user:登錄FTP伺服器的用戶名
//password:登錄FTP伺服器的用戶名的口令;path:FTP伺服器上的路徑
ftpClient=newFtpClient();
ftpClient.openServer(server);
ftpClient.login(user,password);
//path是ftp服務下主目錄的子目錄
if(path.length()!=0)ftpClient.cd(path);
//用2進制上傳、下載
ftpClient.binary();
}

/**
*upload
*上傳文件
*@throwsjava.lang.Exception
*@return-1文件不存在
*-2文件內容為空
*>0成功上傳,返迴文件的大小
*@paramnewname上傳後的新文件名
*@paramfilename上傳的文件
*/
publiclongupload(Stringfilename,Stringnewname)throwsException
{
longresult=0;
TelnetOutputStreamos=null;
FileInputStreamis=null;
try{
java.io.Filefile_in=newjava.io.File(filename);
if(!file_in.exists())return-1;
if(file_in.length()==0)return-2;
os=ftpClient.put(newname);
result=file_in.length();
is=newFileInputStream(file_in);
byte[]bytes=newbyte[1024];
intc;
while((c=is.read(bytes))!=-1){
os.write(bytes,0,c);
}
}finally{
if(is!=null){
is.close();
}
if(os!=null){
os.close();
}
}
returnresult;
}
/**
*upload
*@throwsjava.lang.Exception
*@return
*@paramfilename
*/
publiclongupload(Stringfilename)
throwsException
{
Stringnewname="";
if(filename.indexOf("/")>-1)
{
newname=filename.substring(filename.lastIndexOf("/")+1);
}else
{
newname=filename;
}
returnupload(filename,newname);
}

/**
*download
*從ftp下載文件到本地
*@throwsjava.lang.Exception
*@return
*@paramnewfilename本地生成的文件名
*@paramfilename伺服器上的文件名
*/
publiclongdownload(Stringfilename,Stringnewfilename)
throwsException
{
longresult=0;
TelnetInputStreamis=null;
FileOutputStreamos=null;
try
{
is=ftpClient.get(filename);
java.io.Fileoutfile=newjava.io.File(newfilename);
os=newFileOutputStream(outfile);
byte[]bytes=newbyte[1024];
intc;
while((c=is.read(bytes))!=-1){
os.write(bytes,0,c);
result=result+c;
}
}catch(IOExceptione)
{
e.printStackTrace();
}
finally{
if(is!=null){
is.close();
}
if(os!=null){
os.close();
}
}
returnresult;
}
/**
*取得某個目錄下的所有文件列表
*
*/
publicListgetFileList(Stringpath)
{
Listlist=newArrayList();
try
{
DataInputStreamdis=newDataInputStream(ftpClient.nameList(path));
Stringfilename="";
while((filename=dis.readLine())!=null)
{
list.add(filename);
}

}catch(Exceptione)
{
e.printStackTrace();
}
returnlist;
}

/**
*closeServer
*斷開與ftp伺服器的鏈接
*@throwsjava.io.IOException
*/
publicvoidcloseServer()
throwsIOException
{
try
{
if(ftpClient!=null)
{
ftpClient.closeServer();
}
}catch(IOExceptione){
e.printStackTrace();
}
}

publicstaticvoidmain(String[]args)throwsException
{
FtpUtilftp=newFtpUtil();
try{
//連接ftp伺服器
ftp.connectServer("10.163.7.15","cxl","1","info2");
/**上傳文件到info2文件夾下*/
System.out.println("filesize:"+ftp.upload("f:/download/Install.exe")+"位元組");
/**取得info2文件夾下的所有文件列表,並下載到E盤下*/
Listlist=ftp.getFileList(".");
for(inti=0;i<list.size();i++)
{
Stringfilename=(String)list.get(i);
System.out.println(filename);
ftp.download(filename,"E:/"+filename);
}
}catch(Exceptione){
///
}finally
{
ftp.closeServer();
}
}
}

④ 查看伺服器ftp功能是否正常

當我們購買了雲主機之後,需要上傳網站代碼,此時就需要使用ftp。如何判斷ftp功能是否正常呢?這里先從遠程伺服器的本地ftp說起,教你測試遠程伺服器的本地ftp是否工作正常。

工具/原料
win7 sp1
firefox 31.0
方法/步驟
打開遠程登錄,登錄遠程伺服器

輸入ip地址、賬號和密碼,登錄遠程伺服器(賬號一般是Administrator,以具體情況為准)

打開瀏覽器,在地址欄中輸入ftp://127.0.0.1

在彈出框中輸入ftp的賬號和密碼

列出文件列表,說明伺服器本地的ftp工作正常

如果以3到5步中不能正常進行,說明遠程伺服器的本地ftp本身功能就有問題,更不用說外網連接ftp了。一個簡單的測試辦法,就介紹到這里,希望能夠幫到您。
END
注意事項
如果本地可以正常連接ftp,但是外網登錄ftp卻有問題,可以查看系列經驗的另一篇。

⑤ 如何測試伺服器連接FTP的最大連接性能(迸發數)

同時的概念比較嚴格,如果真的是同時這么多人下載,你的伺服器會受不了的!要做分流了!

⑥ 思科模擬器怎麼做ftp dhcp dns 郵件伺服器搭建的

  • Cisco packet tracer6.2

  • 拓撲圖構建和配置PC

  • 1、根據給出的參考圖,選擇相關設備設計拓撲圖

⑦ 在思科模擬器中完成pc0,pc1到pc2,dhcp,ftp的連通訪問 求詳細步驟和截圖

左側的路由器配置
en
conf t
int f0/0 (靠近PC0的一側,需要自己看圖確定)
ip add 192.168.1.1 255.255.255.0
no shut
int f0/1 (靠近右側路由器的一側,需要自己看圖確定)
ip add 192.168.3.1 255.255.255.0
no shut
exit
ip route 192.168.2.0 255.255.255.0 192.168.3.2
右側路由器配置
en
conf t
int f0/0 (靠近左側路由器的一側,需要自己看圖確定)
ip add 192.168.3.2 255.255.255.0
no shut
int f0/1 (靠近PC2的一側,需要自己看圖確定)
ip add 192.168.2.1 255.255.255.0
no shut
exit
ip route 192.168.1.0 255.255.255.0 192.168.3.1
給左側的PC0和PC1配置網關為192.168.1.1
右側的計算機配置網關為192.168.2.1
兩邊就可以互訪了

⑧ 按照圖示所給地址段,在思科模擬器中完成PC0到DHCP、DNS、FTP連通訪問,並給出詳細設置過程。

pc0配置:
IP:172.16.0.2
mask:255.255.255.0
gateway:172.16.0.1

DHCP配置:
IP:10.0.0.2
mask:255.255.255.0
gateway:10.0.0.1
地址池:10.0.0.4-10.0.0.255 掩碼:255.255.255.0 網關:10.0.0.1 DNS:10.0.0.3

FTP:自動獲取地址

Router0:
enable
configure terminalinterface f0/0
ip address 172.16.0.1 255.255.255.0(為介面配置IP)
no shutdown
interface s1/0
ip address 192.168.1.1 255.255.255.0
no shutdown
ip route 10.0.0.0 255.255.255.0 192.168.1.2 (配置靜態路由)
end
running-config startup-config(保存配置)
Router1:
enable
configure termianl
interface s1/0
ip address 192.168.1.2 255.255.255.0(配置介面IP地址)
no shutdown
interface f0/0
ip address 10.0.0.1 255.255.255.0
no shutdown
exit
ip route 172.16.0.0 255.255.255.0 125.20.0.1 (配置靜態路由)
end
wr(保存配置)

⑨ 如何測試是否與FTP的連接通暢

1. 不用管是否通暢,取遠程FTP文件大小和取下來的文件大小做對比,一樣就OK
2. 真要60S一次也可以:每次丟個臨時文件上去,判斷是否傳上去了,OK後,刪除臨時文件(當然,這個方法可能有點...)
3. socket 判斷 遠程IP的 21埠是否通暢!

⑩ 怎樣用FTP升級cisco交換機

1.首先在自己的計算機上安裝一個tftp的軟體(隨便什麼都可以)2.使用網線把PC和交換機連接起來,這里要注意測試連通性。3.dir flash: 查看IOS的名字 flash tftp 備份原來的IOS tftp flash 升級新的文件Source filename []? c2600-i-mz.122-11.bin (需升級的新IOS映象文件名) Destination filename [c2600-i-mz.122-11.bin]? Do you want to over write? [confirm] Accessing (t ftp://xxx.xxx.xxx.xxx/c3600-i-mz.122-11.bin) 升級文件的地址和路徑Erase flash: before ing? [confirm] Erasing the flash filesystem will remove all files! Continue? [confirm] 這樣就OK了。